Thread Rating:
  • 3 Vote(s) - 3.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Revelator For Everyone
(09-08-2019, 10:48 AM)Old News Wrote:

[To see links please register here]

(09-07-2019, 02:45 AM).Flagg. Wrote:

[To see links please register here]

(09-06-2019, 12:12 PM)Old News Wrote:

[To see links please register here]

When I tried to rip myself and others off, , it made me crash miserably. And I do use the pie menu!

By the way, can someone tell me how to turn off the insufferable slide show or whatever that is on when the viewer opens? A black screen would be better. Non animated stuff, would be better. But those things moving on the screen... just no. Sensorial overload. Yes, I have my reasons, I am not the only one, but I will explain if asked, it's just, important. 

Thank you...

Regarding the crashing, try the big 'Reset All Settings' in Preferences > General , because with no one else reporting crashing on that implicates there is a difference to your system from others.

The splash page can't be turned off in a setting but the web page displayed for it can be changed in debug settings, which fact you can use to still accomplish the same as turning it off.

Play with the two settings SingularitySplashPagePrefix and SingularitySplashPagePath. If you set the Prefix one to something that doesn't resolve at all ( http:// ) and set the Path one blank, you get a black screen.

Okay so thank you. I added just a HTTP:// in there. it gave me an error page, which is much better than that happy-to-go splash page. I love you a bit more now... XD 

Now, the other issue, not so much. After said Reset All Things, I return to relog, and then, 

Right click - tools - inspect - textures - select texture - rip selected texture - crash.
This link is a 

[To see links please register here]

 and I will remove it soon. There was a name for the hosting pictures place but I forgot lol...
You can make it point to a local file like:
file:///C:/mypages/intro.html





Reply
(09-14-2019, 12:21 AM)EEmmerald Wrote:

[To see links please register here]

(09-11-2019, 06:07 AM)RedSecret Wrote:

[To see links please register here]

Great job this Revelator.

I understand that what I am asking has nothing to do with the current debate. My simple problem is that I start the viewer and it appears to me off screen. I close it when it is in full screen mode and opening it again I find it out of screen as before. Installed and uninstalled and installed again. Anything. Some idea?

Thanks

If there is anyone else with the same problem.  Changing DPI works fine, but I found easier way.

Revelator opens on the top left side of 4K 43" monitor.
The top of it is not visible, nor is the [minimize],[maximize],[close] buttons.

Simple solution; Grab the right side of the window and drag to the right, any distance.
Now the top controls are visible.  Maximize it or resize your window.  Tala  Smile

As Flagg mentioned already, this will happen each time, if Revelator crash or it is closed in full screen mode.
The simple dragging to the right works perfectly each time.
I tried that on a few different sizes and resolution monitors - works on all.
Another solution that have always worked for me: Go to Revelator shortcut click on properties/shortcut tab/run. It comes as Normal Window change it to maximized, apply and OK.

[To see links please register here]

Reply
(09-13-2019, 10:51 AM).Flagg. Wrote:

[To see links please register here]

(09-12-2019, 01:51 PM)TheWalkingBread Wrote:

[To see links please register here]

This viewer's working pretty great, but noticed two issues:

1) I'm not able to edit the texture of other people's objects (I have edit permission on them) when it's worn on the other person. Previously in Darkstorm I'm able to edit texture even when it's worn (so I can preview what it looks like on the spot), but now if I apply a UUID nothing happens. No issues when object is rezzed

2) Still getting the exact same error as before on Darkstorm with some Bento objects when trying to build with MeshSL tool. Object is fully rezzed when exporting and pretty sure no issues with cache as I've cleared cache and tried a few times:

[Image: G1GGxVZ.png]

For point 1 try it with hacked god mode turn on Ctrl+Alt+G

For point 2 try a weird trick, export the target with Revelator but log in a official SL viewer and use that cache, or use the SLM tool which get the SLM direct from the server.

Hm tried what you said for #2 and it still has the same issue:

1. Have my main use LL viewer and wear the bento object
2. Have an alt log onto Revelator to export it
3. In Gina's MeshSL tool set cache folder to vanilla viewer location
4. Export, and it pops error

Not sure what you mean by "use the SLM tool which get the SLM direct from the server" though.
Reply
(Yesterday, 12:44 PM).Flagg. Wrote:

[To see links please register here]

(Yesterday, 06:53 AM)Pixarraldo Wrote:

[To see links please register here]

Key Tool and VFS Injector (Local Assets) do not work for animation UUIDs and files.

Having copied an animation UUID then I press Ctrl-Shift+K and I get Key Tool window not fully loaded like this:

[To see links please register here]


VFS Injector has the same problem. Trying to Add a saved animation file fails silently, unlike adding any image file, which succesfully gets added to the local assets list.

I find that when trying to add local animation with VFS Injector a file with same UUID and .anim.tmp extention gets created in the folder where the animation file is stored in computer.

Key Tool does work with texture UUIDs

There's shit going on with UUID's in more details than I know at top of my head and I'm digging into it deeper but what I know so far is that there are two UUID , one is referred as ItemID and one is AssetID.  AssetID will open a few things, textures, sounds, the shit you can use in a LSL script.  For others you need the ItemID, and when the ItemID pass thru the keytool, if it can't directly create the item but it is a valid fetchable item, it should fall through to the hex editor and fill it in, and then you can push Upload on the hex editor.  I'll see if I can find a way to go shorter than that.  You'll note if you look into this, the animation notecards we make and use in the viewer AO that work with a UUID those are the ItemID not the AssetID and is why you can't rip animations directly out of a sale box but if they have a demo stand which put the animation on your avatar, that give the viewer the ItemID.

Trying animation demo stands you get AssetID through the Animation Explorer or Jelly Roll not the ItemID. That is the why I find Key Tool is failing to open the animation UUIDs I have.
Reply
(09-11-2019, 07:59 PM).Flagg. Wrote:

[To see links please register here]

(09-11-2019, 07:02 AM)Bassiswild Wrote:

[To see links please register here]

I think something is wrong with my computer.  I am running Windows 7 Professional.  It keeps crashing and I pulled it up on VS and here are the details.  Exception thrown at 0x0000000076FCA111 (ntdll.dll) in RevelatorAlphaViewer.exe: 0xC0000005: Access violation reading location 0x0000000000000074.  Also when I launch I get a Crash Loop Box appear and says One or More unhandled GL errors. Tells me to pick Yes or No. Yes just closes the box and No launches the viewer.

Make sure you have the most up to date video driver to your card, from the factory not from Windows, but I'm going to guess you already know that if you know how to put the VS debugger to it.  Other suggestions is try enabling and disabling things on the graphics tabs in preferences.  Make certain this debug 'RenderGLCoreProfile' is NOT set to true.

OSX no there is not a version, but its been before said, Wine will run on OSX and the Windows viewer should do there, or put a few gig of your drive aside and put Linux to it, a reasonable Linux install that only has the purpose to run the viewer and a few other basic things can fit in less than twenty gig.  If someone can understand how to compile on Xcode I can put the same things of Revelator code to the Singularity base of their Mac version, I just don't have any way to run OSX here.

Windows 10 didn't want to play nice with my system.  I'll give wine a try.  Also I'm going to be teaching myself how to compile a Singularity viewer on Xcode.  Once I'm okay at it I'll help with compiling for OSX. 
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
Big Grin Revelator Alpha 64 bit viewer lilith969 27 8,080 06-14-2018, 01:04 AM
Last Post: .Flagg.



Users browsing this thread: 1 Guest(s)